Description
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
CVSS breakdown
Affected products
- apache / ActiveMQ5.19.8
- Apache Software Foundation / Apache ActiveMQ0 – 5.19.8
- Apache Software Foundation / Apache ActiveMQ6.0.0 – 6.2.7
- Apache Software Foundation / Apache ActiveMQ All6.0.0 – 6.2.7
- Apache Software Foundation / Apache ActiveMQ All0 – 5.19.8
- Apache Software Foundation / Apache ActiveMQ Stomp6.0.0 – 6.2.7
- Apache Software Foundation / Apache ActiveMQ Stomp0 – 5.19.8