Description
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
CVSS breakdown
CVSS 3.1
Attack Vector
Local
Attack Complexity
High
Privileges Required
None
User Interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High
Affected products
References
- VENDOR_ADVISORYhttps://github.com/git/git/security/advisories/GHSA-xfc6-vwr8-r389
- PATCHhttps://github.com/git/git/commit/f4aa8c8bb11dae6e769cd930565173808cbb69c8
- MISChttps://git-scm.com/docs/git-clone
- MAILING_LISThttps://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/
- MAILING_LISThttp://www.openwall.com/lists/oss-security/2024/05/14/2
- MAILING_LISThttps://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
Updated 23m ago · 8 sources